
 

11 

 

BAB II 

LANDASAN TEORI 

 

II.1. Perancangan Simulasi 

Perancangan simulasi merupakan prosess perancangan model dari suatu 

system nyata (riil) dan pelaksanaan eksperimen – eksperimen dengan model ini 

untuk tujuan memahami tingkah laku system atau menyusun strategi (dalam suatu 

batas atau limit yang ditentukan oleh sebuah satu atau beberapa kriteria) 

sehubungan dengan operasi system tersebut. 

Metode simulasi dapat menjelaskan tingkah laku sebuah system dalam 

beberapa waktu dengan mengobservasi tingkah laku dari sebuah model 

matematika yang disebut sesuai karakter system yang asli, sehingga seorang analis 

bisa mengambil kesimpulan tentang tingkah laku dari system dunia nyata. 

(STIKOMP Digital Library) 

 

II.2. Media Pembelajaran 

Media pembelajaran merupakan alat bantu untuk menyampaikan sesuatu 

dengan lebih menarik, biasanya dengan gambar, video dan animasi yang diputar 

langsung oleh proyektor. Menurut para ahli, media pembelajaran adalah  

teknologi pembawa pesan yang dapat dimanfaatkan untuk keperluan 

pembelajaran. (Akhmad Sudrajat, 1977). 

 



Tujuan media pembelajaran sebagai alat bantu pembelajaran adalah  mempermudah proses 

pembelajaran dikelas, meningkatkan efisiensi pembelajaran dikelas, menjaga relevansi antara 

meteri pelajaran dengan tujuan belajara dan membantu konsentrasi pembelajar dalam proses 

pembelajaran. Media pembelajaran juga bermanfaat dalam motivasi diri karena pengajaran lebih 

menarik perhatian pembelajar, bahan ajar akan lebih jelas makna pengajarannya, metode 

pembelajaran lebih bervariasi dan peserta didik tidak hanya belajar tapi juga mendemonstrasikan 

cara kerja dan bermain dalam quiz yang disediakan media pembelajaran. 

 

II.3. Psikotes atau Psikologi 

Definisi Tes Psikologi atau lebih dikenal sebagai Psikotes adalah tes untuk mengukur 

aspek individu secara psikis.Tes dapat berbentuk tertulis, visual, atau evaluasi secara verbal yang 

teradministrasi untuk mengukur fungsi kognitif dan emosional.Tes dapat diaplikasikan kepada 

anak-anak maupun dewasa.Tes ini dapat berbentuk tertulis, proyektif, atau evaluasi secara verbal 

yang teradministrasi untuk mengukur fungsi atau kemampuan kognitif dan emosional seseorang. 

Tujuan Tes Psikotes digunakan untuk mengukur berbagai kemungkinan atas bermacam 

kemampuan secara mental dan apa-apa yang mendukungnya, termasuk prestasi dan kemampuan, 

kepribadian, intelegensi, atau bahkan fungsi neurologis, dan juga tes psikotes digunakan untuk 

mengukur berbagai kemungkinan atas bermacam kemampuan orang secara mental dan faktor-

faktor yang mendukungnya, termasuk prestasi dan kemampuan, kepribadian, dan intelegensi. 

Jadi sederhananya, psikotes adalah serangkaian kegiatan yang dilakukan untuk mengetahui 

gambaran seseorang mulai dari kemampuan kognitifnya, kondisi emosinya, kecenderungan-

kecenderungan sikap dan hal-hal yang mempengaruhi kecenderungan tersebut. (STAIKAP 

Pekalongan) 



 

II.3.1.  Pengertian Psikologi Atau Psikotes Menurut Beberapa Ahli  

 Ada banyak ahli yang mengemukakan pendapat tentang pengertian psikologi, diantaranya: 

a. Pengertian Psikologi menurut Ensiklopedi Nasional Indonesia Jilid 13 (1990), Psikologi 

adalah ilmu yang mempelajari perilaku manusia dan binatang baik yang dapat dilihat  secara 

langsung maupun yang tidak dapat dilihat secara langsung. 

b. Pengertian Psikologi menurut Dakir (1993), psikologi membahas tingkah laku manusia 

dalam hubungannya dengan lingkungannya. 

c. Pengertian Psikologi menurut Muhibbin Syah (2001), psikologi adalah ilmu pengetahuan 

yang mempelajari tingkah laku terbuka dan tertutup pada manusia baik selaku individu 

maupun kelompok, dalam hubungannya dengan lingkungan. Tingkah laku terbuka adalah 

tingkah laku yang bersifat psikomotor yang meliputi perbuatan berbicara, duduk , berjalan 

dan lain sebgainya, sedangkan tingkah laku tertutup meliputi berfikir, berkeyakinan, 

berperasaan dan lain sebagainya. 

d. Dari beberapa definisi tersebut diatas dapat disimpulkan bahwa pengertian 

psikologi adalah ilmu pengetahuan yang mempelajari tingkah laku manusia, baik sebagai 

individu maupun dalam hubungannya dengan lingkungannya. Tingkah laku tersebut berupa 

tingkah laku yang tampak maupun tidak tampak, tingkah laku yang disadari maupun yang 

tidak disadari. 

Dapat diketahui bahwa pengertian psikologi merupakan ilmu tentang tingkah laku.Pada 

hakekatnya tingkah laku manusia itu sangat luas, semua yang dialami dan dilakukan manusia 

merupakan tingkah laku.Semenjak bangun tidur sampai tidur kembali manusia dipenuhi oleh 

berbagai tingkah laku.Dengan demikian objek ilmu psikologi sangat luas. Karena luasnya objek 
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yang dipelajari psikologi, maka dalam perkembangannya penulis akan membahas tentang 

Psikotes Tanggung Jawab, Psikotes Integritas dan Kejujuran, Psikotes Inisiatif dan Kreatifitas. : 

 

II.3.2.  Psikotes Tanggung jawab 

Psikotes tanggung jawab adalah tes kesadaran manusia akan tingkah laku atau perbuatan 

yang disengaja maupun tidak di sengaja. Tanggung jawab juga berarti berbuat sebagai 

perwujudan kesadaran akan kewajibannya. Tanggung jawab itu bersifat kodrati artinya sudah 

menjadi bagian kehidupan manusia, bahwa setiap manusia pasti di bebani dengan tanggung 

jawab. 

 

 

 

II.3.3  Psikotes Integritas dan Kejujuran 

Psikotes Integritas dan Kejujuran adalah salah satu bentuk tes yang bertujuan untuk 

mengetahui tingkat kematangan dan sikap serta loyalitas pada sebuah perusahaan.Dengan 

melalui tes integritas dan kejujuran dalam tes psikotes seseorang akan diketahui kematangan 

dalam berfikir dan tentunya akan diketahui karakteristik dari orang tersebut. 

 

II.3.4  Psikotes Inisiatif dan Kreatifitas 

 Psikotes Inisiatif adalah sebuah ungkapan yang artinya Membuat terobosan atau langkah 

pertama dalam mengupayakan suatu hal.  Membuat terobosan atau langkah pertama dalam 

mengupayakan suatu hal diistilahkan sebagai Mengambil Inisiatif (ambil inisiatif).  Jadi arti 

Mengambil Inisiatif adalah Membuat terobosan atau langkah pertama dalam mengupayakan 



suatu hal / . Kata Istilah Mengambil Inisiatif merupakan ungkapan resmi dalam Bahasa 

Indonesia. 

Psikotes Kreativitas adalah salah satu kebutuhan pokok manusia, yaitu kebutuhan akan 

perwujudan diri (aktualisasi diri) dan merupakan kebutuhan paling tinggi bagi manusia (Maslow, 

dalam Munandar, 2009). Pada dasarnya, setiap orang dilahirkan di dunia dengan memiliki 

potensi kreatif.Kreativitas dapat diidentifikasi (ditemukenali) dan dipupuk melalui pendidikan 

yang tepat (Munandar, 2009).  

 

 

 

II.3.5  Multimedia 

Menurut (Vaughan,2011), multimedia merupakan sebuah kombinasi dari beberapa 

media yaitu teks, gambar, animasi, suara dan video yang dapat dimanipulasi secara digital dan 

ditampilkan melalui komputer ataupun dengan peralatan manipulasi elektronik dan digital yang 

lain. Suatu multimedia dimana user dapat mengontrol atau berinteraksi dengan elemen – elemen 

multimedia yang terdapat di dalamnya disebut sebagai multimedia interaktif. Contoh dari 

multimedia adalah kios informasi,video game, dan perangkat ajar digital. 

Elemen – elemen yang terdapat dalam multimedia : 

1. Teks 

Teks merupakan media yang penting yang digunakan untuk menyampaikan informasi. Pada 

multimedia, teks digunakan untuk mempermudah user untuk mengerti materi yang ingin 

disampaikan ataupun fungsi – fungsi yang terdapat pada multimedia tersebut. 



Teks pada komputer memiliki style yang berbeda – beda. Menurut vaughan (2011, p25), cara 

paling sederhana untuk mengelompokkan style teks yang ada adalah dengan membedakan 

apakah font dari teks tersebut termasuk serif atau sans. Serif merupakan dekorasi kecil yang 

terdapat pada akhir huruf. Contoh dari font serif adalah Times New Roman, New Century 

Schoolbook, Bookman dan  Palatino. Sedangkan contoh Font sans (dalam bahasa prancis 

adalah yang berarti ”tanpa”) serif  adalah Helvetika, Verdaan, Arial, Optima dan Avant 

Grande. Penggunaan font serif  lebih cocok digunakan untuk Headline atau pernyataan yang 

dicetak tebal dan untuk isi dari media tersebut sebaiknya menggunakan font serif, karena 

dapat menuntun mata pembaca melihat baris – baris teks. 

2. Gambar 

Dibandingkan dengan teks, element multimedia ini memberikan user bayangan mengenai 

materi multimedia secara fisik. Pada komputer, gambar dipresentesikan dalam 2 bentuk, 

yaitu bitmap(titik – titik kecil pada sebuah matriks sederhana) atau vector(bentuk primitif, 

seperti titik, garis, kurva dan bentuk atau poligon). 

Menurut vaughan (2011, p81-82), perbedaan antara bitmap dan vector terdapat terdapat 

pada bagaimana gambar yang ada ditampilkan pada layar komputer. Untuk Bitmap, gambar 

yang sudah dibuat akan langsung ditampilkan sesuai dengan resolusi saat gambar tersebut 

dibuat. Hal ini menyebabkan turunnya kualitas gambar saat ditampilkan pada rosolusi yang 

lain. Sedangkan untuk vector, gambar akan ditampilkan berdasarkan instruksi matematika, 

sehingga saat gambar diubah skalanya menjadi besar ataupun menjadi kecil, maka gambar 

yang ditampilkan akan memiliki kulalitas yang sama seperti gambar yang asli. 

3. Animasi   



Animasi dapat dikatakan sebagai sekumpulan frame gambar yang disusun sedemikian 

rupa dan diperlihatkan secara berurutan dalam waktu yang singkat secara berulang – ulang 

sehingga menghasilkan kesan bergerak. Animasi yang paling sederhana adalah animasi 2D 

(perubahan visual yang menjadikan image terlihat hidup dalam aksis Cartesius x dan y ), 

yang lebih kompleks adalah animasi 2D (ilusi mengenai kedalaman ditambahkan, seperti 

memberi bayangan atau highlight), dan yang paling realitas adalah animasi 3D(penciptaan 

ruang virtual dalam 3 dimensi dan perubahan dihitung dari aksis x, y dan z) (Vaughan, 2011).  

4.Suara 

Selain digunakan untuk mengarahkan user dalam mengunakan atau memahami isi dari 

multimedia, suara juga dapat membuat suasana yang mempengaruhi perasaan user seperti yang 

di inginkan oleh developer multimedia. Bila dibandingkan dengan presentasi multimedia yang 

hanya berisikan teks dan gambar, suara akan memberikan dampak yang besar bila 

penggunaannya dipakai sesuai dengan materi yang ingin di sampaikan.  

Menurut Vaughan (Vaughan, 2011), hal – hal yang perlu diperhatikan dalam memasukan 

elemen suara pada multimedia adalah : 

a. Menentukan format file yang sesuai  

b. Menentukan kapabilitas pemutaran suara dari user akhir 

c. Memutuskan suara – suara y ang dibutuhkan  

d. Memutuskan kapan dan dimana memakai suara  

e. Mencarimaterial sumber suara 

f. Mengedit suara sesuai dengan kebutuhan  

g. Menguji suara agar sesuai dengan multimedia yang akan dibuat 

 



 

 

5. Video  

Merupakan elemen yang paling kompleks dalam multimedia, karena mengabungkan antara 

animasi dan suara. Selain itu, video merupakan media yang paling memikat karen adapat 

membawa user lebih dekat kepada dunia nyata (Vaughan, 2011). Pengunaan video yang baik 

akan membuat materi dari multimedia yang ingin disampaikan dapat diterima oleh pengguna 

dengan baik. 

 

II.3.6  Mengenal Area Kerja Flash 

Sebelum memulai bekerja dengan flash.Ada baiknya kita mengenal area kerja flash 

sendiri. Pada dasarnya baik flash versi Macromedia maupun versi dari adobe, area kerjanya 

terbagi menjadi beberapa bagian, di antaranya menu, toolbox, timeline, stage, dan panel. 

 

Gambar II.1. Tampilan Area Kerja Flash CS6 

(Sumber :okedroid.com) 



 

1. Toolbox 

Di dalam toolbox terdapat macam – macam tool yang bias kita gunakan untuk 

menggambar objek. Toolbox ini terdiri dari beberapa bagian yang selection 

tool,drawing tool, painting tool, dan navigation tool. 

 

Gambar II.2 Toolbox pada Adobe flash CS6 

(Sumber :okedroid.com) 



 

2. Timeline 

Timeline pada Adobe Flash CS6 secara default terletak di bawah stage.Timeline 

berfungsi untuk mengontrol keseluruuhan objek dan animasi yang terdapat pada 

stage. 

 

Gambar II.3 Tampilan Timeline 

(Sumber :okedroid.com) 

 

3. Layer 

Layer dapat di ilustrasikan seperti tumpukan tumpukan yang berisikan obkjek di 

dalamnya.Dengan layer, kita mengatur movie pada stage dan menentukan 

kedalaman atau lapisan suatu objek. 



 

Gambar II.4Layer menentukan kedalaman objek 

(Sumber :okedroid.com) 

 

Untuk menambahkan layer baru, kita dapat memilih menu Insert > Timeline > 

Layer atau dapat mengklik icon yang terdapat pada bagian bawah timeline. 

 

Gambar II.5 Menambahkan layer baru 



(Sumber :okedroid.com) 

 

Terdapat beberapa mode yang dapat dipilih pada layer di antaranya. 

a. Guide layer, berfungsi untuk membuat animasi dengan menggunakan jalur atau track 

berupa garis yang telah dibuat.  

b. Motion layer, digunakan untuk membuat pergerakan animasi tween. 

c. Masking layer, digunkan untuk membuat animasi efek masking. 

4. Frame  

Frame merupakan bagian dari layer yang digunakan untuk mengatur pergerakan animasi. Di 

dalam frame bias terdiri dari iteks, gambar, audio, video, dank ode pemrograman actionscripst.  

Frame terdiri dari beberapa bentuk, di antaranya : 

a. Keyframe, frame yang memilikibentuk bulat hitam, menandakan bahwa di dalamnya 

terdapat objek. 

b. Blank keyframe, frame berbentuk bulat putih, menandakan bahwa frame masih kosong. 

c. Action frame, frame dengan bulatan putih dan terdapat huruf „a‟ menandakan di 

dalamnya terdapat kode program Actionscript. 

d. Frame label, yaituframe yang diberi namalabel yang ditandai dengan bendera warna 

merah. 

 

Gambar II.6 Jenis – Jenis fram 



(Sumber :okedroid.com) 

 

Untuk member label pada frame, buka panel properties dan kemudia pada kolom label, beri 

nama label. Misalnya “startGame”. 

 

Gambar II.7 Pemberian Nama Label 

(Sumber :okedroid.com) 

 

Pada pemrograman Actionscript, label sering digunakan untuk mempermudah navigasi 

seperti pada perintah gotoandStop.gotoAndStop (“startGame”). 

5. Stage  

Stage adalah area putih berbentuk kotak yang terletak di tengah area kotak Flash.Seperti 

istilah stage pada panggung teater, stage di dalam Flash berfungsi untuk menampilkan 

semua objek maupun movie yang berjalan di atasnya. Objek yang di lletakkan pada stage 

bias berupa stage bisa berupa teks, gambar, dan video. 



 

6. Panel properties 

Panel ini menampung semua properti yang terdapat pada tool – tool dalam Flash.Untuk 

mengaktifkannya, pilih menu window > properties.Di bawah ini contoh panel properties 

pada stage. 

 

Gambar II.8Properties Pada Stage 

(Sumber :okedroid.com) 

 

 

 

 



7. Panel Library 

Seperti layaknya perpustakaan, library pada Flash berfungsi menampung semua symbol yang 

telah dibuat maupun hasil impor dari file luar seperti audio, gambar, dll. Untuk menampilkan 

panel library, bias melalui menu Window > Library atau dengan menandakan tombol Ctrl + 

L. 

 

Gambar II.9Panel  Library 

(Sumber :okedroid.com) 

 

8. Mengimpor item ke dalam Library 

Dalam pembuatan animasi dan Game, tidak semua resource bias dihasilkan dengan tool 

Flash, seperti halnya gambar, sudio, dan video. Oleh karena itu, Frame menyediakan 

fasilitas untuk mengimpor data eksternal ke dalam area kerja Flash. 

Untuk mengimpor item ke dalam Flash bias dilakukan dengan memilih File > import. Di 

sana terdapat 4 pilihan untuk melakukan import : 

a. Import to Stage, masukkan resource dan meletakkan langsung pada stage. 



b. Import to Library, memasukkan resource untuk menampungkan terlebih dahulu pada 

Library. 

c. Open External Library, mengambil resurce yang terdapat pada library file Flash lain. 

d. Import Video, memasukkan resource berupa file video. 

9. Panel Action 

Panel ini berfungsi sebagai tempat menuliskan ActionScript.Untuk mengaktifkannya, pilih 

menu Window > Action atau menekan tombol F9. 

 

Gambar II.10 Panel Action 

(Sumber :okedroid.com) 

 

 

 

 

10. Penggunaan Grid 

Grid adalah garis bantu yang memenuhi stage. Grid biasanya digunakan sebagai patokan 

untuk menempatkan objek seperti pada teknik tiling background. 



 

Gambar II.11 Teknik tiling background dengan bantuan grid 

(Sumber :okedroid.com) 

 

Untuk melakukan pengaturan grid, masuk ke menu View > Grid > Edit Grid atau dengan 

menekan tombol Ctrl+Alt+G. 

 

Gambar II.12 Panel Properties pada Grid 

(Sumber :okedroid.com) 

Untuk menampilkan grid, anda perlu mengaktifkan Show grid. 



 

II.4.  Alat Bantu Analisis dan Perancangan 

Dengan metode pendekatan system yang berorientasi objek, maka penulis akan 

menggambarkan bagaimana karakteristik system tersebut dengan menggunakan pemodelan yang 

disebut Unifield Modelling Language (UML). 

Menurut Bambang Hariyanto (2004 : 259) yang dimaksud dengan UML adalah bahasa 

grafis untuk mendokumentasi, menspesifikan dan membangun sistem perangkat lunak.UML 

berorientasi objek, menerapkan banyak level abstraksi, tidak bergantung proses pengembangan, 

tidak bergantung bahasa danteknologi, pemaduan beberapa notasi di beragam metodologi, dan 

usaha bersama dari banyak pihak. 

Namun karena UML merupakan suatu model pengembangan sistem perangkat lunak 

yang berbasis object oriented sehingga menggnuakan bentuk class dan operation dalam konsep 

dasarnya, maka lebih cocok dalam pemrogramannya dengan menggunakan bahasa-bahasa 

pemrograman yang berbasis OOP (Object Oriented Programming) seperti C, C++, Java, VB dan 

lain sebagainya. Menurut Sholiq ( 2006 : 7 ) untuk mendapatkan banyak pandangan terhadap 

sistem informasi yang akan dibangun, UML menyediakan beberapa diagram visual yang 

menunjukkan berbagai aspek dalam sistem. Ada beberapa diagram yang disediakan dalam UML, 

antara lain : 

1. Use Case Diagram  

Use case mendepkripsikan interaksi tipikal antara para pengguna sistem dengan sistem 

itu sendiri, dengan member sebuah narasi tentang bagaimana system tersebut digunakan. Use 

Case Diagram menampilkan actor mana yang menggunakan Use Case mana, Use Case mana 

yang memasukan Use Caselain dan hubungan antara actor dan Use Case. 



2. Activity diagram 

Diagram ini menjelaskan alur kerja suatu sistem.Activity diagram mirip dengan state 

diagram karena sejumlah aktifitas menggambarkan keadaan suatu proses dengan 

memperlihatkan urutan aktifitas yang dijalankan baikberupa pilihan maupun paralel. Diagram ini 

juga berguna untuk menganalisis sebuah use case dengan menggambarkan aksi-aksi yang 

diperlukan dan kapan aksi-aksi tersebut dijalankan. Selain itu, activity diagram dapat 

menjelaskan urutan algoritma yang kompleks dan memodelkan sejumlah aplikasi dengan proses 

parallel. 

 

 

3. Sequence Diagram 

Sequence diagram secara khusus menjabarkan behavior sebuah sekenario tunggal. 

Sequence diagram menunjukan sebuah objek contoh dan pasan-pesan yang melewati objek-objek 

dalam use case. 

4. Collaboration Diagram 

Secara fungsional digram ini hamper mirip dengan sequence diagram. Collaboration 

diagram memfokuskan pada interaksi dan hubungan diantara sekumpulan objek yang 

berkolaborasi. Hubungan-hubungan tersebut memperlihatkan objek actual dan relasi yng terjadi 

diantara mereka yang digambarkan dengan sebuah garis.Diatas garis terdapat alur pesan yang 

dikirim objek yang berhubungan tersebut.Component Diagram. 

5. Class Diagram 



Class diagram mendepkripsikan jenis-jenis objek dalam sistem dan berbagai macam 

hubungan statis yang terdapat diantara mereka. Class diagram juga menunjukan property dan 

operasi sebuah class dan batasan-batasan yang terdapat dalam hubungan-hubungan objek tersebu 

6. Component Diagram 

Component diagram (diagram komponen) adalah diagram yang menunjukkan model 

secara fisik komponen perangkat lunak dalam sistem dan hubungan antar mereka. 

 

 

 

7. Deployment Diagram 

Deployment diagram (diagram deployment) adalah diagram yang menampilkan 

rancangan fisik jaringan dimana berbagai komponen akan terdapat disana. 

 

 

 

 

 


