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BAB IV 

HASIL DAN PEMBAHASAN 

 

IV.1. Tampilan Hasil 

 Adapun hasil dari perancangan program pada proyek game mencari 

perbedaan pada gambar sebagai berikut : 

 

IV.1.1. Halaman Game 

 

Gambar VI.1.1. Halaman Game Level 1. 

 

 

Gambar VI.1.1.1. Halaman Game Level 2. 



50 
 

 
 

 

Gambar VI.1.1.2. Halaman Game Level 3. 

 

Pada halaman game dibuat dari rectangle kemudian di shape dan 

digabungkan dengan objek gambar yang memiliki baground  berwarna hitam 

berbola dengan line tool biru, latar background silver seperti beton yang 

bertuliskan game mencari perbedaan. Desain dibuat menggunakan Software 

CorelDraw X5. Dalam halaman game terdapat objek gambar, judul dan latar 

belakang yang masing-masing diletakkan didalam layer yang berbeda.  

Dalam layer 1 frame1 pada scene level 1 berikan nama layer dengan nama 

Baground1 untuk menempatkan objek gambar pada latar berwarna silver, buat 

kembali layer baru dengan cara klik new layer pada Timeline dan berikan dengan 

nama layer Baground2, lakukan hal yang sama pada pembuatan layer berikutnya 

untuk Baground3. Lakukan import to Stage pada tiap layer untuk menempatkan 

objek yang akan dijadikan latar dalam halaman game dengan cara klik 

File>import>import to stage. Tambahkan layer  baru untuk digunakan sebagai 

penampung label frame. Di panel Timeline buatlah layer baru  dan berikan nama 

layer yaitu label. 



51 
 

 
 

Berikan label untuk frame di layer label sebagai berikut : 

1. Frame 1 : frame_level 1. 

2. Frame 2 : frame_menang 1. 

3. Frame 3 : frame_kalah 1. 

Lakukan hal yang sama untuk level berikutnya, dan rubah instance name masing-

masing sesuai dengan level. Kemudian penulis akan mengatur ulang ukuran pada 

Baground1 dengan width 1500 dan height 1000, pada  Baground3 dengan width 

557,05 dan height 369,20.  

 

IV.1.2. Pencatat Waktu Dalam Hitungan Mundur 

 

 

Gambar IV.1.2. Pencatat Waktu. 

 

1. Di panel Timeline buatlah layer baru dan berikan dengan nama label 

waktu. 

2. Buatlah duah buah kotak dynamic text dan berikan nama variable 

tampil_menit pada kotak sebelah kiri dan nama variable tampil_detik pada 

kotak sebelah kanan. 

3. Seleksi kedua kotak tersebut kemudian klik menu modify>convert to 

symbol berikan nama mc waktu lalu pilih movie clip pada kolom type 

kemudian ok. 

:

  

00  00 
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4. Klik double pada mc waktu untuk mengedit dalam memperpanjang jumlah 

frame, klik kanan frame 12 pilih insert frame. 

5. Berikan nama instance name waktu pada panel properties. 

Selanjutnya penulis akan mengedit Action frame agar objek dapat berfungsi 

dengan baik. Di panel Timeline pilih frame1 pada layer waktu kemudian pilih mc 

waktu sehingga tampil pada properties menjadi Action – Movie clip.  

 

IV.1.3. Cursor Mouse 

 

Gambar IV.1.3. Gambar Cursor Mouse. 

 

 Di panel Timeline buat layer baru dengan nama mouse. Lakukan import 

pada objek mouse yang akan diambil dan jadikan sebagai movie clip, lakukan edit 

dan pilih frame 2 klik Insert Keyframe ganti objek mouse dengan objek yang telah 

diedit. 

 

IV.1.4. Tombol Mulai 

 

 

Gambar IV.1.4. Tombol Mulai. 
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 Pada panel Timeline buatlah layer baru dan berikan nama tombol, seret  

button untuk tombol mulai pada panel Library ke panggung layer tombol dengan 

cara pilih menu Window>Common libraries>buttons, lakukan penempatan pada 

tombol dan letakkan di posisi sebelah kiri bawah dari objek gambar.  

 

IV.1.5. Tombol Petunjuk 

 

 

Gambar IV.1.5. Tombol Petunjuk. 

 

 Di panel Timeline klik layer tombol untuk mengaktifkannya dan penulis 

akan menempatkan tombol petunjuk di layer ini. Lakukan dengan cara pilih menu 

Window>common libraries>button dan seret button yang diinginkan di panel 

library. Klik tombol petunjuk lalu pilih modify>convert to symbol atau F8 berikan 

name mc bantuan dan type movie clip. Klik double tombol petunjuk di layer 

petunjuk, buat layer baru. Klik frame 2 layer 2 lakukan Import objek yang dibuat 

dari CorelDraw X5 untuk dijadikan latar petunjuk.  

Di panel Timeline klik frame 2 layer petunjuk lalu klik kanan Insert 

Keyframe. Hapus action yang ikut dari frame 1 layer petunjuk, pilih tombol 
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petunjuk lakukan pengaturan pada color effect>style>tint berikan nilai 50% 

dengan warna biru. Buat tombol untuk kembali ke permainan, misalkan pada text 

static ketik “X” dibawah latar petunjuk pilih modify>convert to symbol berikan 

name mc xx type button 

 

IV.1.6. Tombol Berhenti 

 

 

Gambar IV.1.6. Tombol Berhenti. 

 

Di panel Timeline klik layer tombol untuk mengaktifkannya dan penulis 

akan menempatkan tombol petunjuk di layer ini. Lakukan dengan cara pilih menu 

Window>common libraries>button dan seret button yang diinginkan di panel 

library. Klik tombol berhenti lalu pilih modify>convert to symbol berikan name 

mc berhenti dan type movie clip. Di panel Timeline klik frame 1 layer berhenti 

lalu klik kanan Insert Keyframe, lakukan pengaturan pada color effect>style>tint 

berikan nilai 50% dengan warna biru. Import objek yang dibuat dari CorelDraw 

X5 untuk dijadikan latar berhenti, buat  2 buah tombol untuk “ya” dan “tidak. 
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IV.1.7. Tombol Musik 

 

 

Gambar IV.1.7. Tombol Musik 

 

Di panel Timeline klik layer tombol untuk mengaktifkannya dan penulis 

akan menempatkan tombol petunjuk di layer ini. Lakukan dengan cara pilih menu 

Window>common libraries>button dan seret button yang diinginkan di panel 

library. Klik tombol berhenti lalu pilih modify>convert to symbol atau F8 berikan 

name mc musik2 dan type movie clip. Klik double tombol musik di layer musik, 

klik frame 1 layer musik, pada sound di panel properties berikan name musik. 

 

IV.1.8. Tombol  Pause dan Lanjut 

 

 

Gambar IV.1.8. Tombol Pause dan Lanjut. 
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Tombol ini berukuran width 76,15 dan height 26  dengan intance name 

btn_jeda, jadikan tombol tersebut sebagai movie clip dengan pilih Button 

pause>Modify>Convert to Symbol dan berikan name mc jeda dengan type movie 

clip. Klik frame 2 layer pause klik button pause pilih swap pada panel properties 

seret button lanjut dan letakkan diatas button pause. 

Tetap di frame 2 lakukan import to stage untuk menerapkan latar 

informasi. Buat layer baru dengan nama action letakkan posisinya diatas layer 

pesan. 

  

IV.1.9. Objek Tanda Beda Lingkaran 

 

 

Gambar IV.1.9. Objek Tanda Beda Lingkaran. 

 

 Di panel Timeline buat layer baru dengan nama permainan. Pada tool box 

pilih oval tool dan buat lingkaran dengan ukuran width 18,50 dan height 18,50. 

Pilih warna fill dengan alpha 35%. Klik kanan objek oval pilih menu 

modify>convert to symbol berikan name beda dan type movie clip, lakukan 

duplikat pada frame 1 dan letakkan pada frame 2. Kemudian group objek oval dan 

lakukan duplikat sebanyak 5, 10 dan 15 pada masing-masing level tertentu. Pilih 
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objek oval berikan instance name beda1 sampai dengan beda5, beda10 dan 

beda15 pada masing-masing level. 

 

IV.1.10. Teks Indikator 

 

 

Gambar IV.1.10. Teks Indikator. 

 

 Buat teks dengan static text dan tuliskan dengan “Cari” dan “Perbedaan 

Lagi” letakkan dengan posisi yang sama dan berikan jarak untuk diletakkan 

dynamic text. Buat kembali teks dengan dynamic text berikan ukuran font 20, 

dengan karakter font courier new pilih warna putih untuk teks static dan warna 

biru untuk dynamic text. Pilih teks dynamic text berikan nama variable di panel 

properties dengan nama hasil.  

 

IV.1.11. Halaman Menang 

 

Gambar IV.1.11. Halaman Menang Level 1. 
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Di panel Timeline buat layer baru dengan nama layer pesan atur posisi 

diatas layer button. Di frame 2 layer pesan buat teks “Horrree... anda Menang 

!!!”  dengan menggunakan text tool pada static text dan berikan warna ungu.  

 

 

Gambar IV.1.11.1. Halaman Menang Level 2. 

 

Pada scene 3 di panel Timeline buat layer baru dengan nama layer pesan 

atur posisi diatas layer button. Di frame 2 layer pesan buat teks “Horrree... anda 

Menang !!!” dengan menggunakan text tool pada static text.  

 

 

Gambar IV.1.11.2. Halaman Menang Level 3. 

Di scene 5 pada panel Timeline buat layer baru dengan nama layer pesan 

atur posisi diatas layer button. Di frame 2 layer pesan buat teks “Horrree... anda 

Menang !!!  The End” dengan menggunakan text tool pada static text. 
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IV.1.12. Halaman Kalah 

 

 

Gambar IV.1.12. Halaman Kalah Level 1. 

 

Di panel Timeline scene 1 layer pesan pada frame 3 buat teks “Huuu... 

anda Kalah!!!”  dengan menggunakan text tool pada static text dan berikan 

warna ungu.  

 

 

Gambar IV.1.12.1. Halaman Kalah Level 2. 

 

Di panel Timeline scene 3 layer pesan pada frame 3 buat teks “Huuu... 

anda Kalah!!!” dengan menggunakan text tool pada static text dan berikan warna 

ungu.  
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Gambar IV.1.12.2. Halaman Kalah Level 3. 

 

Di panel Timeline scene 5 pilih layer pesan, klik pada frame 3 layer pesan 

buat teks “Huuu... Anda Kalah !!!” dengan menggunakan text tool pada static 

text. Buat layer baru kembali dan letakkan diatas layer pesan dengan nama action. 

Buat kembali layer baru dengan nama label dan berikan instance name pada 

properties di frame1 dengan name frame_level 1, di frame 2 berikan dengan name 

frame_menang1 dan di frame 3 berikan dengan name frame_kalah1.  

 

IV.1.13. Tombol Main Lagi 

 

 

Gambar IV.1.13. Tombol Main Lagi. 

 

Di panel Timeline pilih layer pesan, klik pada frame 3 layer pesan lalu 

seret tombol dari Window>Common Libraries>Buttons jadikan button menjadi 

action movie clip. Kemudian klik frame 2 di dalam mc music lakukan klik kanan 

Insert Keyframe. 



61 
 

 
 

IV.1.14. Publish Game 

 Selanjutnya penulis akan melengkapi dengan membuat aplikasi proyek 

game mencari perbedaan pada gambar ini agar dapat dibuka disetiap Personal 

Computer . 

1. Simpan dokumen proyek terlebih dahulu. 

2. Klik menu File>Publish Setting sehingga akan tampil kotak dialog Publish 

Setting. 

 

Gambar IV.1.14. Publish Game. 

 

3. Dalam kotak dialog, tandai kotak Windows Projector lalu klik tombol 

publish. 

4. Tutup kotak dialog dengan mengklik tombol OK. 
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IV.2. Pembahasan 

 Dalam pembuatan Game Mencari Perbedaan Pada Gambar dengan 

menggunakan objek-objek serta fitur-fitur untuk melengkapi game. Pada proyek 

game ini desain permainan berbasis objek 2D. 

 Adapun penjelasan dari beberapa fitur pelengkap game tersebut yaitu 

tombol mulai yang berfungsi sebagai awal dimulainya game dengan waktu 

mundur, tombol petunjuk yang berfungsi sebagai penjelasan dari permainan, 

tombol berhenti yang berfungsi sebagai intruksi dalam mengakhiri permainan, 

tombol musik yang berfungsi sebagai mengaktifkan dan menonaktifkan musik 

dalam bermain, tombol pause yang berfungsi sebagai berhenti sejenak dalam 

bermain, tombol lanjut yang berfungsi untuk melanjutkan game yang dihentikan 

sejenak ketika tombol pause diaktifkan, tombol main lagi berfungsi sebagai 

mengulang game yang tidak dapat diselesaikan oleh pemain dalam waktu yang 

ada sehingga tombol main lagi dipilih untuk dapat memainkan dan menyelesaikan 

permainan agar dapat melanjutkan ke level berikutnya, tombol Level2 dan Level3 

berfungsi untuk melanjutkan ke level2 dan level3 jika di level1 dan level2 berhasil 

menyelesaikan permainan. 

 Game mencari perbedaan pada gambar ini dimainkan hanya untuk single 

player dengan cara memainkannya yaitu pemain mencari potongan objek gambar 

yang berbeda pada tampilan 2 gambar yang di sediakan, jika ditemukan 

perbedaannya lakukan klik pada pointer mouse ke arah gambar yang disebelah 

kiri dari pemain. Game ini memiliki sampai 3 Level, tiap level memiliki batasan 

waktu yang berbeda, pada level 1 waktu diberikan 3 menit, level 2 waktu 
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diberikan 2 menit dan level 3 waktu diberikan 1 menit. Pemain harus bisa 

menyelesaikan game di tiap level agar dapat melanjutkan ke game berikutnya. 

 Dari uraian diatas maka dapat ditarik kesimpulan, game mencari 

perbedaan pada gambar ini merupakan game edukasi yang berbasis Flash dengan 

desai gambar yang memiliki paduan warna yang cerah dan segar sehingga suasana 

game ini jauh lebih hidup dan menarik dilihat serta game ini dilengkapi fitur-fitur 

yang diterapkan pada game. 

 

IV.3. Kelebihan dan Kekurangan Sistem yang Dirancang 

 Adapun kelebihan dan kekurangan dari sistem yang dirancang pada Game 

Mencari Perbedaan pada Gambar ini adalah sebagai berikut : 

1. Kelebihan. 

a. Game mencari perbedaan pada gambar ini berbasis flash dan desain yang 

menarik dari paduan warna yang diberikan sehingga lebih hidup dan 

menarik. 

b. Tersedianya fitur-fitur pelengkap pada game. 

c. Objek yang dibuat telah diterapkan ke dalam ActionScript 2.0 seperti 

frame, movie clip, button dan sound. 

d. Game mencari perbedaan pada gambar ini dapat menjadi game edukasi 

dalam meningkatkan ketangkasan. 

2. Kekurangan. 

a. Game ini hanya dapat dimainkan oleh satu pemain (single player). 

b. Tamplan Objek game masih 2D. 
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c. Game ini hanya memiliki sampai 3 Level. 

d. Cara memainkannya masih menggunakan pointer mouse. 

e. Tidak tersedianya fitur penyimpanan data skore pada game. 

f. Tidak tersedianya fitur fullscreen dan restore untuk tampilan size pada 

game. 

g. Bahasa program masih menggunakan ActionScript 2.0 sehingga sedikit 

lebih lama dalam eksekusi program.  

 

 


